BeerSmith™ Home Brewing Forum

BeerSmith Software => BeerSmith 2 Questions => Topic started by: rx35285 on November 17, 2021, 09:34:26 AM

Title: OG appears "off" and not changing when I add malt
Post by: rx35285 on November 17, 2021, 09:34:26 AM
Returning to BeerSmith after a 2 year layoff.  Can't get my old recipes connected, but that's for another day.  Today I'm trying to modify a helles bock recipe from homebrewing.org.  The BeerSmith estimated OG seems low at 1.046 and it doesn't change when I add malt. I've tried adding a screenshot of the BeerSmith page but can't figure that out.

The BH effy is locked at 72%.  Equipment is 4 gal pot - extract.  What else should I check?

Thanks!
Dave



Title: Re: OG appears "off" and not changing when I add malt
Post by: BeerSmith on November 17, 2021, 10:27:19 PM
Hi,
  The problem is that BeerSmith 3 now takes into account the alcohol tolerance of the yeast, a field which did not exist in BeerSmith 2.  For old BeerSmith 2 recipes imported it is using a default of 10% alcohol tolerance for beer yeasts, which is why you are running into this limit.

   Most of the BeerSmith 3 yeast records have been updated to include the actual alcohol tolerance where I could find it - at least for the major yeast providers.
So you can try the following:
   - Reselecting (or substituting the yeast) for the BeerSmith 3 yeast record will often update the alcohol tolerance for the yeast strain
   - Choosing another yeast strain may also get you higher alcohol tolerance as the new yeast strains do have the field set where data is available
   - Finally you can edit the yeast strain itself within your recipe and set the alcohol tolerance higher, though I would check the manufacturer's web site to make sure the yeast can handle it

Brad
Title: Re: OG appears "off" and not changing when I add malt
Post by: rx35285 on November 22, 2021, 12:35:04 PM
Thanks for the help.  This software is simply amazing.  It was easy to use when I was using it regularly and is so powerful.

I haven't moved to BeerSmith 3 yet, but I will once I get settled back into BeerSmith 2.  Need to get reconnected to my old recipes, ingredients, equipment profile, etc.

ANYWAY, I noticed that switching the type from extract to partial mash changes the OG so that it matches what homebrewing.org says it should be and the software then responds when I start adding DME.  I'm sure it's operator error on my part, but do you have any suggestions on where I might be goofing up?

Thanks!   
Title: Re: OG appears "off" and not changing when I add malt
Post by: rx35285 on January 01, 2022, 03:33:16 PM
Posting an update in case someone finds this via the search function.  The problem was that I added 2 lbs of DME and categorized it as "grain" instead of "extract".  I'm going to call that a newbie error since life changes have kept me away for 2 1/2 years.  Also contributing to my problems is that I renamed my original BeerSmith directory while creating a hard drive backup process.  Cheers!
Title: Re: OG appears "off" and not changing when I add malt
Post by: brewdown on January 07, 2022, 10:29:50 AM
Posting an update in case someone finds this via the search function.  The problem was that I added 2 lbs of DME and categorized it as "grain" instead of "extract".  I'm going to call that a newbie error since life changes have kept me away for 2 1/2 years.  Also contributing to my problems is that I renamed my original BeerSmith directory while creating a hard drive backup process.  Cheers!

Thanks for the update, I'm still trying to learn this stuff too.  Have you checked out the BeerSmith Youtube channel?  They have a lot of good content I find helpful, here is the channel if you're interested: https://www.youtube.com/c/MrBeersmith (https://www.youtube.com/c/MrBeersmith)