Brewing Topics > All Grain/Advanced

Efficiency issue

(1/21) > >>

KernelCrush:
The last many brew sessions I have had a terrible time trying to hit my OG. Some mashes have gone on for hours.  And still didn't finish according to where they should be.  I stopped them, they didn't.  So I figured I would mimic a recipe exactly, and who better than Gordon Strong. But the latest bout last weekend I hit the pleasantly magical number of 42%.  Had to adjust with other fermentables that aren't shown in the recipe.  My mash pH was 5.6 room temp, I hit every temp within a degree and every volume within the accuracy of my graduated stick.  My meter was calibrated, my graduated stick has been checked many times recently.  Based on above I am starting to blame my crush pic attached. https://www.dropbox.com/s/1dsrpx37t7vr5tw/20140324_190959.jpg But it looks OK to me?  And recipe is attached. Have I messed up a setting somewhere in the software?  I don't get it.  Been staring at this crap for weeks.  Thanks for any help.

cmbrougham:
When is the last time you checked the accuracy of your thermometer that you use for measuring mash temperatures?

grathan:
You've got %60 mash efficiency and then 3 gallons lost to trub and fermenter loss.


%42 is Brewhouse efficiency not mash efficiency, You understand the difference right?


Your predicting %72 brewhouse efficiency so you're setting yourself up for failure because you never reach the estimated %85 mash eff.


Change the brewhouse efficiency in your equipment profile to %42 if you want more accurate gravity predictions from the software.




KernelCrush:

--- Quote ---When is the last time you checked the accuracy of your thermometer that you use for measuring mash temperatures?
--- End quote ---

Yes I have a thermometer on every vessel for guidance and I cross check it with a DTQ450X every time.


--- Quote ---You've got %60 mash efficiency and then 3 gallons lost to trub and fermenter loss.
%42 is Brewhouse efficiency not mash efficiency, You understand the difference right?

--- End quote ---

Yes I hope I understand but I've been terribly terribly wrong before.  I have never had the problem til recently using the same settings. Always had settings at 70% brewhouse. 

texasdan:
Deleted by poster.

Navigation

[0] Message Index

[#] Next page

Sitemap 
Go to full version