Author Topic: Hydrometer problem????  (Read 2992 times)

Offline Fortunete11er

  • BeerSmith Apprentice Brewer
  • **
  • Posts: 5
  • BeerSmith 2 Rocks!
Hydrometer problem????
« on: March 06, 2016, 03:22:11 PM »
Well I used my hydrometer today and either its broken or I did something wrong.  Finished my 60 minutes at 152* and then measured....it actually floated where there was no reading.  Is this the wrong device maybe or?????  LOL.  I thought it was supposed to sink a bit to give me a number.

Offline Fortunete11er

  • BeerSmith Apprentice Brewer
  • **
  • Posts: 5
  • BeerSmith 2 Rocks!
Re: Hydrometer problem????
« Reply #1 on: March 06, 2016, 03:43:45 PM »
I'll bet I used the wrong type of Hydrometer damn it....I think I got a proof hydrometer.  Uhhhhh.

Offline Oginme

  • BeerSmith Grandmaster Brewer
  • *****
  • Posts: 3150
  • Goats, guitars, and a home brew; Life is good!
    • Longvu LaManchas
Re: Hydrometer problem????
« Reply #2 on: March 06, 2016, 04:45:55 PM »
Did you cool the wort down to room temp to take a reading?  You may have the wrong hydrometer, but even with the right model, it will not be very accurate if the wort is not close to the calibration temperature of the hydrometer, which is printed on the scale.
Recycle your grains, feed them to a goat!

Offline Fortunete11er

  • BeerSmith Apprentice Brewer
  • **
  • Posts: 5
  • BeerSmith 2 Rocks!
Re: Hydrometer problem????
« Reply #3 on: March 06, 2016, 06:00:31 PM »
I put it in the feezer to get it down to temp and it still was bobbing way like a hollow rubber duck above the wort, no way to read a single number, it should have sunk even if the temps were not right....right?  LOL

Offline Oginme

  • BeerSmith Grandmaster Brewer
  • *****
  • Posts: 3150
  • Goats, guitars, and a home brew; Life is good!
    • Longvu LaManchas
Re: Hydrometer problem????
« Reply #4 on: March 06, 2016, 06:15:12 PM »
If it was a proof & tralle hydrometer , yes.
Recycle your grains, feed them to a goat!