Author Topic: Ingredient not displayed in recipe View?  (Read 11662 times)


  • Guest
Re: Ingredient not displayed in recipe View?
« Reply #15 on: August 23, 2008, 02:42:06 PM »
OK, I've gotten this sorted now.

Previous to this, when I reinstalled BeerSmith, it never walked me through any of that setup stuff.  This, despite the fact that I uninstalled if from the control panel, removed the folder from "C:\Program Files\BeerSmith" and even edited my registry to remove all mentions of BeerSmith.   Additionally I ran Vista's disk cleanup everytime I uninstalled and reinstalled.

I went through this routine 4 times. Each time the problem remained.

Then I ran an advanced search in Vista on the string 'beersmith'.

What I found was a directory within "C:\Users\username\AppData\Local\VirtualStore" which had backups of all of the contents of "C:\Program Files\BeerSmith"

To be extra anal, I deleted every single reference to BeerSmith that my advanced search found (which included my recipes which I backed up elsewhere. (Though I'm 99% sure all I needed to eliminate was the content of the VirtualStore

I removed this, turned the computer off all the way, re-downloaded BeerSmith and reinstalled it.  Everything looks OK so far.


  • Guest
Re: Ingredient not displayed in recipe View?
« Reply #16 on: August 24, 2008, 06:07:37 AM »
Just another update, this is definitely resolved.  I used BeerSmith for about an hour last night and have been using it during this morning's brew session without any problems.  I've been adding, editing, deleting, and moving recipes around and have started, closed and opened BeerSmith several times and everything is working great.

Offline BeerSmith

  • Brewer, Author, Patriot
  • BeerSmith Administrator
  • BeerSmith Grandmaster Brewer
  • *****
  • Posts: 5605
  • BeerSmith - take the guesswork out of brewing!
    • BeerSmith
Re: Ingredient not displayed in recipe View?
« Reply #17 on: August 26, 2008, 07:45:12 PM »
  I just found out about the virtual store under Vista which is apparently the reason many people have this problem and it does not go away.

  This should work:
  - Close BeerSmith (you don't want it running here)
  - Go to C:\Program Files\BeerSmith  (under Vista) using file explorer
  - Click on the "Compatability Files" icon on the explorer toolbar in Vista
  - Now delete the "newopts14.opts" file
  - Open up BeerSmith

Thanks very much for finding this!!  Apparently under Vista the files get stored to this compatibility directory if you don't have direct permission to the Program Files directory.

Get a free trial of BeerSmith 3 here

Offline BrewWhat

  • BeerSmith Brewer
  • ***
  • Posts: 30
Re: Ingredient not displayed in recipe View?
« Reply #18 on: September 23, 2008, 08:13:10 PM »
A lot of times when you delete a program they leave Registry entries on your computer. To get a full removal delete your program using the add / remove programs in the control panel and then use a registry cleaner (such as CCleaner) to remove left overs from your removal.
Brewing 5 years
AG 4 years.