Author Topic: Vista Service Pack 1  (Read 2972 times)

GreatGobo

  • Guest
Vista Service Pack 1
« on: June 29, 2008, 12:45:55 PM »
I recently upgraded Vista to SP1 and found that the upgrade seems to have caused issues with BeerSmith. I thought I should share my experiences in the hope that it might help someone else. After the upgrade to SP1, I found that BeerSmith would no longer access any of the new data that I had entered into the program. I couldn't view my recipes, my grains, etc. Experimenting, I made a copy of the whole directly structure from C:\Program Files\BeerSmith and copied it to another location (in my case, my desktop). When I ran BeerSmith.exe (by double clicking on it) from outside 'Program Files', all of my edits and additions showed up in the program.

I tried a few of the suggestions on the forums from deleting the *.opts file to changing file permissions. No change. I uninstalled and reinstalled with no luck. I uninstalled and removed all references to beersmith in the registry and then reinstalled. I then copied over my back up *.bsm files with no avail.

After reinstalling again, I tried replacing all *.bsm files from my back up location into the 'Program Files' location. If I double click a *.bsm file from within the 'Program File' directory, the file loads without my edits. If I double click it from my back up location (which is just a copy of all files from C:\Program Files\BeerSmith before reintalling), my edits show up. One other oddity occurred when I changed a *.bak file to *.bsm in C:\Program Files\BeerSmith. A file name Recipe_1.bsm after changing bak to bsm, would load properly when double clicked from C:\Program Files\BeerSmith. But when I changed that same file to Recipe.bsm and then double clicked it from C:\Program Files\BeerSmith, my edits would not show up.

I did find that the following worked.
1) Start BeerSmith from my copied location and then export all of my changes.
2) Run BeerSmith from the start menu. (In my case it's been reinstalled already, I don't know if this would have worked without a reinstall.)
3) Import my edits that were exported in step 1.

After the import, everything so far seems to be working. I'm able to make new edits and save them and still see them after closing and restarting the program.
« Last Edit: June 29, 2008, 01:01:01 PM by GreatGobo »

Offline BeerSmith

  • Brewer, Author, Patriot
  • BeerSmith Administrator
  • BeerSmith Grandmaster Brewer
  • *****
  • Posts: 5568
  • BeerSmith - take the guesswork out of brewing!
    • BeerSmith
Re: Vista Service Pack 1
« Reply #1 on: June 29, 2008, 03:26:57 PM »
Hi,
  It sounds to me like a permissions problem.  If BeerSmith does not have write access, it can't write to the directory.

  I've been running Vista SP1 for some time, and I personally did not have any problems.

  My guess is that the reinstall you did reset the permissions on the directory so you could write to it again.

Cheers,
Brad
Get a free trial of BeerSmith 3 here