Author Topic: BeerSmith3 on Ubuntu 22.04 (error and fix)  (Read 143 times)

Offline andyfarke

  • BeerSmith New Brewer
  • *
  • Posts: 1
  • BeerSmith 2 Rocks!
BeerSmith3 on Ubuntu 22.04 (error and fix)
« on: May 08, 2022, 09:56:11 AM »
I recently upgraded my Ubuntu distro from 20.04 to 22.04. This new version of Ubuntu uses OpenSSL 3.0 (versus the old OpenSSL 1.1), which creates the following error when attempting to run BeerSmith3:

    beersmith3: error while loading shared libraries: libssl.so.1.1: cannot open shared object file: No such file or directory

I'm assuming this will be fixed in a future build of BeerSmith, but for now I was able to resolve things by following the directions here: https://linuxpip.org/install-openssl-linux/

I suspect this is not an ideal solution, but it got things working for me. Posting here in case anyone else gets similar errors.

Offline jomebrew

  • Global Moderator
  • BeerSmith Grandmaster Brewer
  • *****
  • Posts: 1052
    • Jomebrew
Re: BeerSmith3 on Ubuntu 22.04 (error and fix)
« Reply #1 on: May 09, 2022, 10:31:35 AM »
That should be a good work around. 

I usually create a new symbolic link for older libs to the new lib after upgrading linux and breaking applications.