Author Topic: Ingredients missing again!  (Read 5994 times)


  • Guest
Ingredients missing again!
« on: April 12, 2009, 06:12:58 PM »
Hello fellow homebrewers,

All my ingredients are missing from when I open up a recipe. When I click on "Preview Brewsheet" everything is as it should be.  I've dealt with this in the past twice before and both times required a simple fix.  However this time things aren't so easy and I can't seem to get my recipes back. 

A little background info:
- I've already searched through this site and other homebrew forums looking for a solution but none has worked.

- I'm using Vista.  This has happened to me once before on XP and once on Vista.

- Options.bsm file had previously been deleted

- newopts14.opt was deleted last night but didn't fix the problem

- I then exported all my recipes to my "Documents" folder and uninstalled Beersmith and deleted anything else Beersmith related on my PC besides those recipes.  Every time I re-install Beersmith I don't have to enter my passkey and all my recipes are already there and the current situation hasn't changed.  I did this twice and am now stuck and don't know what to do.

I'd appreciate any and all advice.  I plan on brewing an RIS later this week and would like to get this fixed before brewday. 


Offline BeerSmith

  • Brewer, Author, Patriot
  • BeerSmith Administrator
  • BeerSmith Grandmaster Brewer
  • *****
  • Posts: 5605
  • BeerSmith - take the guesswork out of brewing!
    • BeerSmith
Re: Ingredients missing again!
« Reply #1 on: April 13, 2009, 07:08:08 AM »
  Have you checked the compatibility directory -

  Under Vista you may also have a "Compatibility files" directory that shows up on the toolbar when you go to the BeerSmith directory.  This is where your data and the opts file likely lives.  The full path to the compatibility diectory is:  C:\Users\{USERNAME}\AppData\Local\VirtualStore\Program Files\BeerSmith

  where USERNAME is your login name for Vista.

If you delete the newopts14.opts directory there you should be in business.   However if that does not work there is also a patch available here:

Finally - if all of that fails you can try uninstalling (make a backup) and then just install BeerSmith to a subdirectory under your Documents directory.  In some ways this is the best option as it bypasses all of the "Vista features" that complicate backing up your recipes and files.

  I apologize for the problem - some of it is inherent in the way Vista handles Program files, and I'm working to restructure the storing of files in the future version.

Get a free trial of BeerSmith 3 here


  • Guest
Re: Ingredients missing again!
« Reply #2 on: April 13, 2009, 12:00:56 PM »
Thanks Brad, I'll give this a shot and keep you posted.



  • Guest
Re: Ingredients missing again!
« Reply #3 on: April 13, 2009, 12:13:00 PM »
Found and deleted "newopts14.opt" in the Compatability Files.  Problem solved.  Thanks a ton, Brad.



  • Guest
Re: Ingredients missing again!
« Reply #4 on: August 05, 2009, 06:46:42 PM »
This fix also works in Windows 7 (RC) if you find yourself having the same problem.