Author Topic: Adjust temps for equipment only updates when field is unchecked then checked  (Read 2382 times)

Offline m750

  • BeerSmith Brewer
  • ***
  • Posts: 47
  • Brewing, Farming, Running
    • thebottlefarm
I'm seeing an issue calculating infusion temperature. It seems that the temps are incorrectly specified if you adjust the tun temp or grain temp. They return to a default configuration. If you uncheck 'Adjust temps for equipment' then recheck it the values are then correctly updated. They appear to be correct based on past experience with my tun.

Im using 2.1.02 on mac os 10.8.5.
Thanks,
Aaron


Offline BeerSmith

  • Brewer, Author, Patriot
  • BeerSmith Administrator
  • BeerSmith Grandmaster Brewer
  • *****
  • Posts: 5568
  • BeerSmith - take the guesswork out of brewing!
    • BeerSmith
Aaron,
  They should update if you set them within the recipe itself.  They will not update if you set a Profile value outside of a recipe (since a recipe contains its own copy of everything).  This is done so you don't arbitrarily change a recipe you built a year or two ago and may have already brewed.

Brad
Get a free trial of BeerSmith 3 here

Offline m750

  • BeerSmith Brewer
  • ***
  • Posts: 47
  • Brewing, Farming, Running
    • thebottlefarm
I think I figured out what was happening. If you check the box, but do not save the changes, it does not readjust the values for sparging temp when adjusting grain temp or tun temp.
If you check it, then save, it seems to function fine.
AO

 

modification