Author Topic: Brewlog - Fermentation tab, Measured Efficiency bug with OG 1.031  (Read 2391 times)

Offline stiltzkin

  • BeerSmith Apprentice Brewer
  • **
  • Posts: 5
  • BeerSmith 2 Rocks!
Noticed this today. Tried on two different recipes.

BeerSmith: 2.1.02

Open a recipe under your brewlog and open the Fermentation tab.
If I enter:
Measured Batch Size: 7.3 liters
Measured OG: 1.031

BS calculates Measured Efficiency to 69.1%

If I now go back and enter 7.3 liters in "Measured Batch Size" the "Measured Efficiency" goes up to 71.4%(!). Same values, I just re-entered "Measured Batch Size".

If I now change the "Measured OG" to the same value 1.031 (delete everything in the box and type 1.031) and hit Tab the "Measured Efficiency" go back to 69.1%.

It should be calculated to the same value regardless of which order I enter the values. Am I missing something here?

Offline brewfun

  • BeerSmith Grandmaster Brewer
  • *****
  • Posts: 2292
  • Malt dust is just alcohol's glitter
Re: Brewlog - Fermentation tab, Measured Efficiency bug with OG 1.031
« Reply #1 on: November 01, 2013, 12:42:51 AM »
I'm not able to replicate this error. I'm suspecting a rounding error in the batch volume.

I'm wondering what happens if you increase the number of decimal spots for batch volume. Try this: Options > Units > Batch Volume Units. Increase the precision to 2 decimal places.

If that's not the issue, then we should look at other factors, like the equipment profile or specifics of the recipe.
Beer Appreciation is the space between pints.

Offline stiltzkin

  • BeerSmith Apprentice Brewer
  • **
  • Posts: 5
  • BeerSmith 2 Rocks!
Re: Brewlog - Fermentation tab, Measured Efficiency bug with OG 1.031
« Reply #2 on: November 02, 2013, 03:11:25 PM »
Batch Volume Units is set to 2.

I can't reproduce this with other numbers than 7.3 and 1.031. It's just these two.