• Welcome to the new forum! We upgraded our forum software with a host of new boards, capabilities and features. It is also more secure.
    Jump in and join the conversation! You can learn more about the upgrade and new features here.

beersmith ubuntu 17.04

McRai

New Forum Member
Joined
Jan 22, 2014
Messages
2
Reaction score
0
i upgrade my ubuntu 16.10 to 17.04..but beersmith don't work....the previous version also the last...Thank
 

McRai

New Forum Member
Joined
Jan 22, 2014
Messages
2
Reaction score
0
thereis nobody with the same problem..!!! :'( :'( :'(
 

Whippeter

New Forum Member
Joined
Aug 14, 2017
Messages
1
Reaction score
0
Hi McRai,

I encountered the same problem when I recently upgraded to ubuntu 17.04. From what I've read, it seems that BeerSmith requires version 12 of libpng but that version is not included in 17.04.

I managed to get around the issue and use BeerSmith by installing version 12 on libpng

You can find and download this package at the links below, it will then install through the Ubuntu Software Center

64bit https://packages.ubuntu.com/xenial/amd64/libpng12-0/download

32bit https://packages.ubuntu.com/xenial/i386/libpng12-0/download
 

bhanson

Apprentice
Joined
Jan 12, 2014
Messages
16
Reaction score
0
I think that at this point it's safe to say that everyone not running a really old variant of Linux can no longer run Beersmith except under Wine.  It just needs to be rebuilt, but we haven't seen anything yet.  It's a shame, because the main reason I bought it initially was solely to support Linux software development. 
 

oteixeira

Apprentice
Joined
Oct 24, 2012
Messages
3
Reaction score
0
Does it work on 18-04?  Also, does anyone know if BS3 will work at ALL on linux?  I am an all linux user as well, and don't want to pay for the pre-upgrade if they don't plan to continue to develop/work in linux.  It seems based on the lack of updates for new OS releases that the linux build is dead.  Kind of sad.

Orlando
 

trinkner

Apprentice
Joined
Feb 15, 2014
Messages
7
Reaction score
0
I can't get Beersmith2 to run on Ubuntu 18.04.

Running from the terminal so as to see error messages:

richard@richard-Lemur:~$ beersmith2
15:17:17: SLib::Init - logging started
15:17:18: GetDocumentsDir() returning: /home/richard/.beersmith2/
Segmentation fault (core dumped)
 

bigchicken

Master Brewer
Joined
Nov 20, 2011
Messages
67
Reaction score
2
Location
Lincoln, Nebraska
It appears Beersmith 3 should work in Linux Ubuntu in late July. That is the whole reason I'm buying it now, to have 1 copy on my Windows PC and 1 copy on my Linux laptop. If development of the Linux version doesn't keep pace with the Windows version, I won't continue the product past 1 year.
 
Top