• Welcome to the new forum! We upgraded our forum software with a host of new boards, capabilities and features. It is also more secure.
    Jump in and join the conversation! You can learn more about the upgrade and new features here.

Equipement on Recipe Page keeps defaulting to unknown Equipement ~ MAC

bschoenb

Apprentice
Joined
Dec 26, 2010
Messages
23
Reaction score
0
I've set up my equipment on the equipment page and saved it... It's still there and looking good.  When I select it for a recipe it takes it, show the revision to boil volume etc...

After saving it and reopening, the recipe page equipment changes some of the defaults in the recipes equipment that I entered to something else..  Boil off, cooling loss,

It won't save it when closing the recipe and revises it to something else..

It's a MAC
 

bschoenb

Apprentice
Joined
Dec 26, 2010
Messages
23
Reaction score
0
I believe this has something to do w/the "calculate for Boil Volume" button.

When I unclick this button off the recipe page as well off the Equipment page.... the System becomes stable again.   
 

BeerSmith

Staff member
Administrator
Grandmaster Brewer
Joined
Apr 5, 2003
Messages
5,814
Reaction score
52
Location
Virginia
Hi,
  The recipe has its own independent copy of equipment in it - and will have your old settings unless you update it.  This was true in V1.4 as well.  The reason is that some people do change their equipment settings over time, but the recipe reflects your equipment settings as they were when you brewed the beer.  Also a complete copy is needed to share recipes with others.

  Try the following:
  - Create a blank recipe
  - Select your new equipment profile into it using the equipment button
  - Use the "Set as Default" button on the menu bar to save your current recipe as the default
  - Now all future recipes will use the equipment settings you just applied

  You can also accomplish the same thing by going to Options->Brewing and then
selecting your equipment profile there and pressing OK.

  Note that this will not change the equipment profile in your existing recipes - as I mentioned above
every recipe has its own independent copy of an equipment profile.

  Finally - I do recommend using the "Calculate Boil Volume" button as this makes sure that all
of your losses and settings are accounted for.

Brad
 

bschoenb

Apprentice
Joined
Dec 26, 2010
Messages
23
Reaction score
0
Yep ~ I concur with what you said:

However, the issue is not that.  Somehow with the Calc Boil volume Clicked the equipement that has been selected and saved in the recipe is changed; to something that is was never previously entered.
For example :

My Personal Kettle has a 1.19 boil off that I entered and saved in my euipement with Zero cooling rate and a specific heat of .12. That stays the same and never changes in the My Equipement Tab. When I select that particular piece of equipemnt and add it to my recipe it appears correct and everything seems fine.  When I save the recipe and exit and then return to the recipe, many of the fields of my personal kettle  are changed within the recipe to things I never entered, while it still stays the same and correct in the My Equipment tab.  The boil has changed to .71; the kettle specific heat is changed to .32, the cooling number is changed to 4%. None of these I have entered anywhere previously.  This new data now feeds the recipe and is now permenent in the recipe thus changing the amount of water I need from 4.44 gallons to 4.09.    In the My equipment tab the profile  has not changed and it is still correct.   

When I change the parameter to unclick the "calc boil volume" and save the recipe that way, the fields for the equipement in my recipe are not changed.  Somehow clicking the "Calc Boil Volume" on the recipe page changes the actaul equipement parameters when it is saved ?

I wish I could send you a pic.........
 

BeerSmith

Staff member
Administrator
Grandmaster Brewer
Joined
Apr 5, 2003
Messages
5,814
Reaction score
52
Location
Virginia
Could you send me a recipe along with the equipment profile?

For example - export the recipe using the "Export Sel" button to export one item, then do the same thing from your equipment profiles.  Send me the two files and I will take a look at it.

Also - just a hunch but is it possible that the "top up water" is set to something large in your equipment profile - I have had a few people who started with an extract equipment profile as a starting point and forgot to set that field to zero when moving to all grain.

Brad
 

bschoenb

Apprentice
Joined
Dec 26, 2010
Messages
23
Reaction score
0
Attached is the recipe and the equipment profile:

 

Attachments

  • Sample Equipment.bsmx
    1.2 KB · Views: 182
  • Sample Recipe .bsmx
    24 KB · Views: 172
  • Sample Recipe .bsmx
    24 KB · Views: 170
  • Sample Equipment.bsmx
    1.2 KB · Views: 184

BeerSmith

Staff member
Administrator
Grandmaster Brewer
Joined
Apr 5, 2003
Messages
5,814
Reaction score
52
Location
Virginia
OK,
  I tried this here.

  I imported your equipment profile (which actually had a mash tun specific heat of 0.21, Calc boil volume checked, a 3 gallon post boil volume, boil off of 1.19 and 4.19 gal total boil volume) and put it in my equipment profiles permanently.

  Then I imported your recipe and put it in My Recipes folder.

  I opened your recipe, clicked on the equipment button and selected your equipment profile.  Then I checked it - all looked good so I pressed OK and saved the recipe.
 
  Then I opened the recipe, checked it again and all of the equipment was the same as your original imported profile.

  Then I closed the program, opened it again and checked the recipe equipment settings - still no change.

  Not sure exactly what's going on - the settings here all stayed the same.  However I am running a slightly newer version (albeit I don't recall making any changes to this part of the program).  I'm publishing the latest version (build 40) very shortly for everyone.

  It looks like it is storing the equipment properly.

Brad
 

bschoenb

Apprentice
Joined
Dec 26, 2010
Messages
23
Reaction score
0
Yeah~ Fiqures.. For two days it did the same thing over and over; and when I opened it to upload to you it seemed to have gone away for me as well....


Sometimes, you just got to chalk it up to the  Gremlins.  If it does it again repeatly, I'll upload the files again.

Thanks Brad~  I'm falling in love w/the new program though! ::)
 
Top