• Welcome to the new forum! We upgraded our forum software with a host of new boards, capabilities and features. It is also more secure.
    Jump in and join the conversation! You can learn more about the upgrade and new features here.

Style numbers off

johnsimmons

Apprentice
Joined
Mar 14, 2011
Messages
8
Reaction score
0
I just noticed that in BS 2.0.40 the style numbers are off by 1 'letter' - there are no 'A's for any style (1A, 2A, etc.) and everything is shifted up one letter so that Dortmunder Export is '1F' instead of '1E' - and the same for all other styles. This problem seems to be the same for all Style Guides. I this this was working in previous 2.0 releases - but am not sure when it might have changed.

John
 

BeerSmith

Staff member
Administrator
Grandmaster Brewer
Joined
Apr 5, 2003
Messages
5,807
Reaction score
50
Location
Virginia
John,
  I don't recall making any changes in this area, and for some reason on my clean install I just did here it is all displaying correctly (at least for the BJCP style guide).  I just checked both my Mac and PC versions, build 40.  I also checked a few recipes and they appear to be correct (for example my Dry Stout is 13A in Samples).

  So I went back and used build 40 to open some earlier style guides (i.e. build 36, 37, 38) and those were also correct.

  Is anyone else seeing this problem?  Were you part of the beta test (which may be an issue due to much earlier builds)?

Brad
 

johnsimmons

Apprentice
Joined
Mar 14, 2011
Messages
8
Reaction score
0
Yes, I was a beta tester but don't recall seeing this before. I just reinstalled 2.0.40 after first renaming the previous BeerSmith2 folder - and I get the same problem. I then installed build 35 (using a previous folder that I renamed) and it had the correct style numbers. Can I copy the style.bsmx file from that build to the 40 install?

I've attached a screen shot of the faulty style list.

John
 

Attachments

  • styles.JPG
    styles.JPG
    31.2 KB · Views: 343

johnsimmons

Apprentice
Joined
Mar 14, 2011
Messages
8
Reaction score
0
I just reinstalled a 3rd time after deleting both BeerSmith2 folders (in Program Files and My Documents) and now ALL IS OK! Not sure what took care of it since I thought I did a similar 'clean' install the last time. Anyway, sorry to cause some confusion.

John
 
Top