• Welcome to the new forum! We upgraded our forum software with a host of new boards, capabilities and features. It is also more secure.
    Jump in and join the conversation! You can learn more about the upgrade and new features here.

Upgrading BeerSmith 2.2 and BeerSmith 2.2 Issues

BeerSmith

Staff member
Administrator
Grandmaster Brewer
Joined
Apr 5, 2003
Messages
5,952
Reaction score
77
Location
Virginia
All,
  I have posted a number of fixes to BeerSmith 2.2 over the past few days.  If you are having trouble with the program or automatically upgrading the program please do the following:

  - Download the latest version directly from http://beersmith.com/download-beersmith
  - Make sure BeerSmith.exe is not running (even in the background - i.e. check the task manager and force quit it if needed)
  - Install the latest version you just downloaded

  This should resolve any issues with the program not upgrading properly via the background download and also should resolve a number of bugs found at launch.

Thanks,
Brad
 

mpizzurro

Apprentice
Joined
Nov 29, 2013
Messages
15
Reaction score
0
Thanks for all the help.  Pretty sure I was able to download it.  Is there any way to be certain I was successful.  Does it say 2.2 when you open the program or anything like that ?
 

Oginme

Grandmaster Brewer
Joined
Mar 16, 2013
Messages
3,186
Reaction score
27
Location
New Hampshire, US
In BeerSmith, click on 'help' on the menu bar, then click on 'about BeerSmith'.  On the left hand side of the pop up window, you should see the version number you are running.  Right now the build is 2.2.10
 

markvonneumann

New Forum Member
Joined
Dec 4, 2013
Messages
1
Reaction score
0
Just to report.
My Ubuntu 64-bit version asked to auto update today, but it ended up downloading the 32 bit package, which caused an error in the upgrading process.
I managed to update manually, through the package on the website, but I'm reporting anyway in case you don't know about the issue.
 

BeerSmith

Staff member
Administrator
Grandmaster Brewer
Joined
Apr 5, 2003
Messages
5,952
Reaction score
77
Location
Virginia
Thanks - I fixed this in the latest two builds, so it should update correctly from now on.

markvonneumann said:
My Ubuntu 64-bit version asked to auto update today, but it ended up downloading the 32 bit package, which caused an error in the upgrading process.
 

donmc85

New Forum Member
Joined
Jan 7, 2014
Messages
2
Reaction score
0
I recently updated to 2.2 and there is an issue with both timers.  When either timer reaches 52min they reset to 0 and the "next step" timer changes to 1hr 50min.  This occurs no matter what the total time of boil or mash is.  It can be triggered by using the set button to change the time to 52min.  It did not occur prior to the update.  I have tried reinstalling the newest version, installing the older version and updating from the old version.  The os is Windows XP Pro 2002 service pack 3.
 

BeerSmith

Staff member
Administrator
Grandmaster Brewer
Joined
Apr 5, 2003
Messages
5,952
Reaction score
77
Location
Virginia
I'm not seeing the timer issue on my Win 7 version - I tried manually setting the timer to 51 min and it does not roll over as you describe.  I'm wondering if the issue might be recipe specific?

Could you send me a copy of the recipe you are having trouble with?  Right click on the recipe and select "Export selected" to save it to a BSMX file and then email it to beersmith at my beersmith.com address.

Brad
 

LarryTate

Apprentice
Joined
Dec 11, 2010
Messages
6
Reaction score
0
I did a new install on my Ubuntu machine, which I run under Wine. The previous version worked flawlessly. However, now I get an error message and BS crashes on startup:

Unhandled exception: page fault on read access to 0x05d1fffc in 32-bit code (0x7855aca0).
Register dump:
CS:0073 SS:007b DS:007b ES:007b FS:0033 GS:003b
EIP:7855aca0 ESP:0033c224 EBP:0033c22c EFLAGS:00010612(  R- -- DI  -A- - )
EAX:0e61ba94 EBX:00000000 ECX:016d6630 EDX:00000000
ESI:05d1fffc EDI:0b87a8dc
Stack dump:
0x0033c224:  0e455354 00000000 0033c248 78556695
0x0033c234:  05d21020 001c6740 0e455354 001c6740
0x0033c244:  0033c324 0033c260 78484b34 05d21020
0x0033c254:  0e45535e 001c6740 0e455354 0033c278
0x0033c264:  78484c01 05d21020 0722a9af 001c6740
0x0033c274:  0722a9aa 0033c290 7848f414 05d21020
Backtrace:
=>0 0x7855aca0 in msvcr90 (+0x3aca0) (0x0033c22c)
  1 0x78556695 in msvcr90 (+0x36694) (0x0033c248)
  2 0x78484b34 in msvcp90 (+0x4b33) (0x0033c260)
  3 0x78484c01 in msvcp90 (+0x4c00) (0x0033c278)
  4 0x7848f414 in msvcp90 (+0xf413) (0x0033c290)
  5 0x78493088 in msvcp90 (+0x13087) (0x0033c2b0)
  6 0x78496113 in msvcp90 (+0x16112) (0x0033c2d0)
  7 0x00521f27 in beersmith2 (+0x121f26) (0x0033d24c)
0x7855aca0: repe movsl (%esi),%es:(%edi)
Modules:
Module Address Debug info Name (128 modules)
PE   400000-  af0000 Export          beersmith2
PE 78480000-7850d000 Export          msvcp90
PE 78520000-785c3000 Export          msvcr90
ELF 7b800000-7ba43000 Deferred        kernel32<elf>
  \-PE 7b810000-7ba43000 \              kernel32
ELF 7bc00000-7bce3000 Deferred        ntdll<elf>
  \-PE 7bc10000-7bce3000 \              ntdll
ELF 7bf00000-7bf04000 Deferred        <wine-loader>
ELF 7cdb1000-7cdda000 Deferred        mpr<elf>
  \-PE 7cdc0000-7cdda000 \              mpr
ELF 7cdda000-7ce54000 Deferred        wininet<elf>
  \-PE 7cde0000-7ce54000 \              wininet
ELF 7ce54000-7cf00000 Deferred        urlmon<elf>
  \-PE 7ce60000-7cf00000 \              urlmon
ELF 7d028000-7d09c000 Dwarf          ieframe<elf>
  \-PE 7d030000-7d09c000 \              ieframe
ELF 7d09c000-7d0dc000 Deferred        usp10<elf>
  \-PE 7d0a0000-7d0dc000 \              usp10
ELF 7d10a000-7d125000 Deferred        spoolss<elf>
  \-PE 7d110000-7d125000 \              spoolss
ELF 7d125000-7d148000 Deferred        localspl<elf>
  \-PE 7d130000-7d148000 \              localspl
ELF 7d148000-7d16e000 Deferred        p11-kit-trust.so
ELF 7d26e000-7d277000 Deferred        librt.so.1
ELF 7d277000-7d2c2000 Deferred        libdbus-1.so.3
ELF 7d2c2000-7d2ea000 Deferred        libk5crypto.so.3
ELF 7d2ea000-7d3b9000 Deferred        libkrb5.so.3
ELF 7d3b9000-7d3cb000 Deferred        libavahi-client.so.3
ELF 7d3cb000-7d408000 Deferred        libgssapi_krb5.so.2
ELF 7d408000-7d474000 Deferred        libcups.so.2
ELF 7d480000-7d493000 Deferred        gnome-keyring-pkcs11.so
ELF 7d493000-7d499000 Deferred        libxfixes.so.3
ELF 7d499000-7d4a4000 Deferred        libxcursor.so.1
ELF 7d4a6000-7d4aa000 Deferred        libkeyutils.so.1
ELF 7d4aa000-7d4b3000 Deferred        libkrb5support.so.0
ELF 7d4b3000-7d4c1000 Deferred        libavahi-common.so.3
ELF 7d797000-7d7c0000 Deferred        libexpat.so.1
ELF 7d7c0000-7d7fa000 Deferred        libfontconfig.so.1
ELF 7d7fa000-7d80b000 Deferred        libxi.so.6
ELF 7d80b000-7d80f000 Deferred        libxcomposite.so.1
ELF 7d80f000-7d81a000 Deferred        libxrandr.so.2
ELF 7d81a000-7d825000 Deferred        libxrender.so.1
ELF 7d825000-7d82b000 Deferred        libxxf86vm.so.1
ELF 7d82b000-7d82f000 Deferred        libxinerama.so.1
ELF 7d82f000-7d853000 Deferred        imm32<elf>
  \-PE 7d840000-7d853000 \              imm32
ELF 7d853000-7d85a000 Deferred        libxdmcp.so.6
ELF 7d85a000-7d87b000 Deferred        libxcb.so.1
ELF 7d87b000-7d881000 Deferred        libuuid.so.1
ELF 7d881000-7d89b000 Deferred        libice.so.6
ELF 7d89b000-7d9d0000 Deferred        libx11.so.6
ELF 7d9d0000-7d9e3000 Deferred        libxext.so.6
ELF 7d9e3000-7d9ec000 Deferred        libsm.so.6
ELF 7d9ec000-7da9d000 Deferred        winex11<elf>
  \-PE 7da00000-7da9d000 \              winex11
ELF 7da9d000-7db3c000 Deferred        libfreetype.so.6
ELF 7db3c000-7db69000 Deferred        msacm32<elf>
  \-PE 7db40000-7db69000 \              msacm32
ELF 7db69000-7dc1f000 Deferred        winmm<elf>
  \-PE 7db70000-7dc1f000 \              winmm
ELF 7dc1f000-7dd63000 Deferred        oleaut32<elf>
  \-PE 7dc40000-7dd63000 \              oleaut32
ELF 7dd63000-7dec4000 Deferred        ole32<elf>
  \-PE 7dd80000-7dec4000 \              ole32
ELF 7dec4000-7df3a000 Deferred        shlwapi<elf>
  \-PE 7ded0000-7df3a000 \              shlwapi
ELF 7df3a000-7e178000 Deferred        shell32<elf>
  \-PE 7df50000-7e178000 \              shell32
ELF 7e178000-7e265000 Deferred        comdlg32<elf>
  \-PE 7e180000-7e265000 \              comdlg32
ELF 7e265000-7e2a6000 Deferred        winspool<elf>
  \-PE 7e270000-7e2a6000 \              winspool
ELF 7e2a6000-7e2dd000 Deferred        uxtheme<elf>
  \-PE 7e2b0000-7e2dd000 \              uxtheme
ELF 7e2dd000-7e30f000 Deferred        libcrypt.so.1
ELF 7e30f000-7e3c4000 Deferred        libsqlite3.so.0
ELF 7e3c4000-7e40b000 Deferred        libhx509.so.5
ELF 7e40b000-7e41a000 Deferred        libheimbase.so.1
ELF 7e41a000-7e444000 Deferred        libwind.so.0
ELF 7e444000-7e449000 Deferred        libgpg-error.so.0
ELF 7e449000-7e468000 Deferred        libp11-kit.so.0
ELF 7e468000-7e47a000 Deferred        libtasn1.so.3
ELF 7e47a000-7e494000 Deferred        libz.so.1
ELF 7e494000-7e4aa000 Deferred        libroken.so.18
ELF 7e4aa000-7e4e0000 Deferred        libhcrypto.so.4
ELF 7e4e0000-7e580000 Deferred        libasn1.so.8
ELF 7e580000-7e601000 Deferred        libkrb5.so.26
ELF 7e601000-7e609000 Deferred        libheimntlm.so.0
ELF 7e609000-7e68d000 Deferred        libgcrypt.so.11
ELF 7e68d000-7e753000 Deferred        libgnutls.so.26
ELF 7e753000-7e78f000 Deferred        libgssapi.so.3
ELF 7e78f000-7e7aa000 Deferred        libsasl2.so.2
ELF 7e7aa000-7e7c1000 Deferred        libresolv.so.2
ELF 7e7c1000-7e7d0000 Deferred        liblber-2.4.so.2
ELF 7e7d0000-7e822000 Deferred        libldap_r-2.4.so.2
ELF 7e841000-7e891000 Deferred        wldap32<elf>
  \-PE 7e850000-7e891000 \              wldap32
ELF 7e891000-7e8b6000 Deferred        iphlpapi<elf>
  \-PE 7e8a0000-7e8b6000 \              iphlpapi
ELF 7e8b6000-7e8e9000 Deferred        ws2_32<elf>
  \-PE 7e8c0000-7e8e9000 \              ws2_32
ELF 7e8e9000-7e905000 Deferred        wsock32<elf>
  \-PE 7e8f0000-7e905000 \              wsock32
ELF 7e905000-7e98e000 Deferred        rpcrt4<elf>
  \-PE 7e910000-7e98e000 \              rpcrt4
ELF 7e98e000-7e9ff000 Deferred        advapi32<elf>
  \-PE 7e9a0000-7e9ff000 \              advapi32
ELF 7e9ff000-7eade000 Deferred        gdi32<elf>
  \-PE 7ea10000-7eade000 \              gdi32
ELF 7eade000-7ec4d000 Deferred        user32<elf>
  \-PE 7eaf0000-7ec4d000 \              user32
ELF 7ec4d000-7ed6c000 Deferred        comctl32<elf>
  \-PE 7ec50000-7ed6c000 \              comctl32
ELF 7ed6c000-7ed79000 Deferred        libnss_files.so.2
ELF 7ed79000-7ed85000 Deferred        libnss_nis.so.2
ELF 7ed85000-7ed9e000 Deferred        libnsl.so.1
ELF 7ef9e000-7efe1000 Deferred        libm.so.6
ELF 7efe1000-7efe5000 Deferred        libxau.so.6
ELF 7efe5000-7f000000 Deferred        version<elf>
  \-PE 7eff0000-7f000000 \              version
ELF b73b2000-b73b7000 Deferred        libdl.so.2
ELF b73b7000-b756b000 Deferred        libc.so.6
ELF b756c000-b7587000 Deferred        libpthread.so.0
ELF b7587000-b7590000 Deferred        libnss_compat.so.2
ELF b75a0000-b75a5000 Deferred        libcom_err.so.2
ELF b75a6000-b76ea000 Dwarf          libwine.so.1
ELF b76ec000-b770e000 Deferred        ld-linux.so.2
ELF b770e000-b770f000 Deferred        [vdso].so
Threads:
process  tid      prio (all id:s are in hex)
0000000e services.exe
0000001f    0
0000001e    0
00000018    0
00000017    0
00000015    0
00000010    0
0000000f    0
00000012 winedevice.exe
0000001c    0
00000019    0
00000014    0
00000013    0
0000001a plugplay.exe
00000020    0
0000001d    0
0000001b    0
00000021 explorer.exe
00000022    0
00000023 (D) C:\Program Files\BeerSmith2\BeerSmith2.exe
00000026    0
00000025    0
00000024    0 <==
System information:
    Wine build: wine-1.4.1
    Platform: i386
    Host system: Linux
    Host version: 3.11.0-15-generic
 

LarryTate

Apprentice
Joined
Dec 11, 2010
Messages
6
Reaction score
0
I've done a complete re-install now. But I'm having the same error message I described above. Ugh.
 

Pirate Point Brewer

Grandmaster Brewer
Master Brewer
Joined
Dec 17, 2008
Messages
190
Reaction score
1
Location
Luna Pier, Michigan AKA - Pirate Point
I've only experience one extremely minor issue with Win 7, build 2.2.12 and earlier. I hope I'm not repeating something that has already been addressed.

If, on the side toolbar, you click "Ingredients" to drop down the list and select and ingredient type, say "Yeast" and then open a strain and close it, you can not click on "Yeast" to select another strain unless you first select another ingredient type, say "Grain", then back to "Yeast", or click on "Ingredients" to re-drop the selection list.

I'm certainly no programmer, but this acts exactly like You were selecting "Ingredients" from the top menu bar. This is true for any sidebar selection.
This is not a big deal. It just makes the use of the side tool bar no more convenient than the selections at the top. Which defeats the purpose of having the side bar.

I'm guessing this happens because you are just calling the same functions from side as top.

Pat
 
Top