• Welcome to the new forum! We upgraded our forum software with a host of new boards, capabilities and features. It is also more secure.
    Jump in and join the conversation! You can learn more about the upgrade and new features here.

Water/Grain ratio is corrupted in BeerXML output file

papat06

Apprentice
Joined
Jun 24, 2011
Messages
5
Reaction score
0
Hello,

although I have 2.6 l/kg in the mash step displayed, I got a corrupted string in XML file:
<MASH_STEPS>
<MASH_STEP>
<NAME>Mash In</NAME>
<VERSION>1</VERSION>
<TYPE>Infusion</TYPE>
<INFUSE_AMOUNT>9.8800000</INFUSE_AMOUNT>
<STEP_TIME>75.0000000</STEP_TIME>
<STEP_TEMP>65.6000000</STEP_TEMP>
<RAMP_TIME>2.0000000</RAMP_TIME>
<END_TEMP>65.6000000</END_TEMP>
<DESCRIPTION>Add 9.88 l of water at 72.5 C</DESCRIPTION>
<WATER_GRAIN_RATIO>o &#400;&#780;&#14048;&#1110;&#42618;&tilde;&#13280;&#1120;</WATER_GRAIN_RATIO>
<DECOCTION_AMT>0.00 l</DECOCTION_AMT>
<INFUSE_TEMP>72.5 C</INFUSE_TEMP>
<DISPLAY_STEP_TEMP>65.6 C</DISPLAY_STEP_TEMP>
<DISPLAY_INFUSE_AMT>9.88 l</DISPLAY_INFUSE_AMT>
</MASH_STEP>
</MASH_STEPS>
(I even have to remove some special characters which corrupt the forum preview (I guess seen as HTML tags)
for some recipes, I also got an empty field (which is acceptable as I did not use it in my post processing)
<WATER_GRAIN_RATIO></WATER_GRAIN_RATIO>


it v1.4 it was:
<WATER_GRAIN_RATIO>2.61</WATER_GRAIN_RATIO>

Maybe this file is computed from other values and there is some unit conversion issues.

Regards,
Patrick
 

BeerSmith

Staff member
Administrator
Grandmaster Brewer
Joined
Apr 5, 2003
Messages
5,884
Reaction score
67
Location
Virginia
Sorry,
  I did not catch this in testing. However I just did a quick check in build 40 and it appears that the field is empty when I export it in many cases.

  I promise I will correct this in the next build.

Brad
 
Top