Author Topic: "Deleted stale lock file" error, nothing in my home directory  (Read 3708 times)

Offline TheFunkyMonk

  • BeerSmith New Brewer
  • *
  • Posts: 2
  • BeerSmith 2 Rocks!
Hi Brad,

I'm on a Macbook Pro running OS X 10.10.2 and BeerSmith 2 v2.2.12.

I'm getting the error "Deleted stale lock file '/Users/myusername/BeerSmith2-myusername'" every time I open the app.

I did a search of your forum for this error before submitting this post, and saw a few threads where you suggested deleting this file manually in your User directory after confirming BeerSmith is not running. I've looked for this file and it doesn't seem to exist in my home directory.

Any thoughts on how I might proceed from here?

Thanks,
R.J.

Offline BeerSmith

  • Brewer, Author, Patriot
  • BeerSmith Administrator
  • BeerSmith Grandmaster Brewer
  • *****
  • Posts: 5561
  • BeerSmith - take the guesswork out of brewing!
    • BeerSmith
Re: "Deleted stale lock file" error, nothing in my home directory
« Reply #1 on: April 22, 2015, 07:53:22 PM »
Hi,
  If it is consistently being put there that indicates that somehow BeerSmith is not shutting down correctly each time you use it.  Do you get any errors when closing BeerSmith down?

Brad
Get a free trial of BeerSmith 3 here

Offline TheFunkyMonk

  • BeerSmith New Brewer
  • *
  • Posts: 2
  • BeerSmith 2 Rocks!
Re: "Deleted stale lock file" error, nothing in my home directory
« Reply #2 on: April 26, 2015, 12:02:38 PM »
Hi Brad,

I'm not getting any errors shutting down Beersmith and am just using the usual cmd+q shortcut. Is there any way I can provide you with a log or more information that might help diagnose what's going on?

Thanks,
R.J.

Offline McGruber

  • BeerSmith Apprentice Brewer
  • **
  • Posts: 3
  • BeerSmith 2 Rocks!
Re: "Deleted stale lock file" error, nothing in my home directory
« Reply #3 on: January 14, 2016, 01:30:30 PM »
Hi Brad,

I'm on a Macbook Pro running OS X 10.10.2 and BeerSmith 2 v2.2.12.

I'm getting the error "Deleted stale lock file '/Users/myusername/BeerSmith2-myusername'" every time I open the app.


I'm having the same issue on my iMac.  OS X 10.10.5 and BeerSmith 2 v2.2.12, and also cannot figure out what to do.  Any suggestions?