Author Topic: Unable to add/edit any recipe.  (Read 902 times)

Offline dparsley63

  • BeerSmith Apprentice Brewer
  • **
  • Posts: 5
  • BeerSmith 2 Rocks!
Unable to add/edit any recipe.
« on: May 16, 2020, 06:38:57 PM »
Has anyone else encountered this problem?  I have never had any problems creating my own recipes on BS3, but a few weeks ago I opened the program and it said another copy was running.  I've seen that issue before and went to find the lockfile to delete it and never found it.  Also, that was when I noticed all my recipe files located in "My Recipes" were missing.  I've tried reinstalling, checked for permissions, etc.  Nothing has worked to this point.  I resorted to purchasing Brewers Friend and when my subscription ends on BS3, that will be the last time I use this disaster of software.  Haven't been able to find any support for any problems I've encountered in the past either.  Gotta know when to say when.

Dennis

Offline Kevin58

  • BeerSmith Grandmaster Brewer
  • *****
  • Posts: 554
  • God is great, beer is good and people are crazy
Re: Unable to add/edit any recipe.
« Reply #1 on: May 17, 2020, 07:14:43 AM »
The most common reason for the another copy running message occurs when you the computer is shut down while BS is running. There are archival processes that occur when Beersmith is closed and if they are not allowed to complete their task the software thinks it has not yet shut down. The best practice is to shut down BS when you are finished using it. If you simply minimize or leave it running and your machine is turned off or the operating system performs an update which includes a re-boot overnight then you will wake up to this issue.
If you?re stressing over homebrewing, you?re doing something wrong.
- Denny Conn

Offline BOB357

  • BeerSmith Grandmaster Brewer
  • *****
  • Posts: 686
  • Beer is my bucket list!
Re: Unable to add/edit any recipe.
« Reply #2 on: May 17, 2020, 02:44:04 PM »
To add to what Kevin said:

To get your files back, select Recover from Backup from the File menu and select the backup from the latest date. A simple post asking for help on the subject would have had you back up and running in no time.
Bob