BeerSmith™ Home Brewing Forum

BeerSmith Software => BeerSmith 2 Bugs/Support => Topic started by: MunkyGenius on September 01, 2017, 07:38:56 PM

Title: BeerSmith2 not installing on Debian 9
Post by: MunkyGenius on September 01, 2017, 07:38:56 PM
Hi there,
I am having some trouble installing BeerSmith2 on Debian 9, I have tried to install all the required dependencies, however the one I am stuck on is alsa-base, it seems like there isn't a package available for Debian 9.

Any advice on how I can get BeerSmith2 installed on Debian 9 would be greatly appreciated

Thanks!
Title: Re: BeerSmith2 not installing on Debian 9
Post by: bhanson on September 16, 2017, 09:26:54 AM
I have been using Beersmith 2 with Debian 64 bit for years now without issue.  Until now, when some of its gtk dependencies seem to be too outdated.  However, I've never had issue installing.  What errors are you getting?  I assume you're opening a root terminal and then dpkg -i Beersmith.......deb.

Title: Re: BeerSmith2 not installing on Debian 9
Post by: vafan on November 05, 2017, 12:29:41 AM
I got the same problem.

"beersmith2 need alsa-base"

I found information that "alsa--base" should be part of "alsa-utils". I got alsa--utils installed and tried to reinstall alsa-utils but no luck.

Solution: I downloaded old version of alsa-base from here: https://packages.debian.org/jessie/all/alsa-base/download

Title: Re: BeerSmith2 not installing on Debian 9
Post by: jawsfree on May 03, 2020, 08:38:27 AM
I got the same problem.

"beersmith2 need alsa-base"

I found information that "alsa--base" should be part of "alsa-utils". I got alsa--utils installed and tried to reinstall alsa-utils but no luck.

Solution: I downloaded old version of alsa-base from here: https://packages.debian.org/jessie/all/alsa-base/download


I tried and it let me install but when i go to launch beersmith 2 it just spins , nothing ever happens.
that allowed to install without error but now it only shows beersmith icon with circle spinning and nothing else happens.