• Welcome to the new forum! We upgraded our forum software with a host of new boards, capabilities and features. It is also more secure.
    Jump in and join the conversation! You can learn more about the upgrade and new features here.

2.3.7_17_amd64 Debian (Jessie) stable Gtk-CRITICAL

vafan

Apprentice
Joined
Jun 12, 2011
Messages
7
Reaction score
0
Location
Sweden
Can't open Beersmith2 after installation.

"Logfile":

(beersmith2:2362): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion 'width >= -1' failed

(beersmith2:2362): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion 'width >= -1' failed

Anyone have a solution?
 

BeerSmith

Staff member
Administrator
Grandmaster Brewer
Joined
Apr 5, 2003
Messages
5,809
Reaction score
50
Location
Virginia
OK - I will certainly take a close look at that.  It appears to be opening a bitmap with negative width.  Not sure why yet... could you find the ~/.beersmith/Opts.xml file and send it to me possibly?  Email it to beersmith at beersmith.com

Brad
 

magjo67

Apprentice
Joined
Jun 28, 2016
Messages
10
Reaction score
0
Location
Göteborg
I get the same error when I am using KDE as windowing platform.

grey:~$ beersmith2
00:53:14: SLib::Init - logging started

(beersmith2:11918): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion 'width >= -1' failed

(beersmith2:11918): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion 'width >= -1' failed
Segmentation fault

But if I connect to the same machine with x2go using Mate or LXDE, beersmith is running as it should.

But I really dont want to remote my own machine.
 

newkirk

Apprentice
Joined
Apr 15, 2016
Messages
5
Reaction score
0
I too get this error, though the reverse of Magjo67 - I NEED to run it remotely but it has suddenly started failing remotely (same system where it worked before) with:

Code:
18:44:36: SLib::Init - logging started
06:44:36 PM: Debug: Failed to connect to session manager: SESSION_MANAGER environment variable not defined

(beersmith2:1795): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion 'width >= -1' failed

(beersmith2:1795): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion 'width >= -1' failed
Vector smash protection is enabled.
java version "1.7.0_79"
OpenJDK Runtime Environment (IcedTea 2.5.5) (7u79-2.5.5-0ubuntu0.14.04.2)
OpenJDK 64-Bit Server VM (build 24.79-b02, mixed mode)
^CSegmentation fault (core dumped)

Beersmith2 is installed on an Ubuntu Trusty 64bit system, running the GUI on a remote Debian Jessie system over SSH, which for months until the past few days worked fine  It DOES still work when I run it locally on the Ubuntu system.  Unfortunately that's NOT where I need it, and it's not installable on the Debian system I'm using as a front-end. (Arm CPU)

Beersmith 2.3.7_14.

j
 

newkirk

Apprentice
Joined
Apr 15, 2016
Messages
5
Reaction score
0
Wanted to add that if I move/remove the ~/.beersmith2 folder it WILL WORK.  After re-entering registration info and restoring the latest files from the backed-up config folder, it stops again.

Then I tried hiding the .beersmith2 folder, ran it about 6 times in trial mode and it worked fine.  Then I entered the registration information, and from then on it fails with the same error, only change being that it's now registered.

j
 

newkirk

Apprentice
Joined
Apr 15, 2016
Messages
5
Reaction score
0
Further detail that may help diagnosis.

I STILL get the gtk errors EVEN WHEN IT WORKS.  (in the past I habitually ran it remotely with "beersmith2 >/dev/null 2>&1 &" command line, so never saw the gtk errors until I went looking for output/errors)  But after those errors one of two things comes next from my perspective - either the window asking about registration opens, or Beersmith crashes with a core dump, depending on whether it's registered.

When run locally the splash window appears empty for a second or three, then less than one second after the name/logo appears within that window the window closes followed a few seconds later by the registration window or the main window - remotely, the empty window appears and immediately closes followed by the gtk errors.  Then it thinks a moment, and the registration window opens or the segfault message appears and it's over.

If I replace opts.xml and .bsopts from a backup of the un-activated .beersmith2 folder it reverts to working again, simply asking each time about registration.  Once registered it will always crash before opening the main window when run remotely, though it still runs locally on that machine.

So it really looks like there's something different taking place when the reg window opens that prevents the full crash from occurring.  And the GTK errors are triggered apparently by the Beersmith2 splash, and may or may not directly relate to the crash. 

j
 

newkirk

Apprentice
Joined
Apr 15, 2016
Messages
5
Reaction score
0
Just wanted to note that the same problem still exists with 2.3.12_14.amd64.deb release.

j
 

jdoklovic

New Forum Member
Joined
Feb 3, 2017
Messages
2
Reaction score
0
I've discovered that it's a problem with the regkey at startup time.

To do this, I booted up a clean beersmith2 mutltiple times in trial mode. Then, I opened up the opts.xml and simply added my reg key and next restart it core dumps.
If I remove the reg key again from opts.xml it works again in trial mode. There must be something with the reg check at startup that's causing the crash.

I need this fixed ASAP so the software is usable.
 
Top