• Welcome to the new forum! We upgraded our forum software with a host of new boards, capabilities and features. It is also more secure.
    Jump in and join the conversation! You can learn more about the upgrade and new features here.

BeerSmith3 on Ubuntu 22.04 (error and fix)

andyfarke

New Brewer
Joined
Jun 11, 2017
Messages
1
Reaction score
0
I recently upgraded my Ubuntu distro from 20.04 to 22.04. This new version of Ubuntu uses OpenSSL 3.0 (versus the old OpenSSL 1.1), which creates the following error when attempting to run BeerSmith3:

    beersmith3: error while loading shared libraries: libssl.so.1.1: cannot open shared object file: No such file or directory

I'm assuming this will be fixed in a future build of BeerSmith, but for now I was able to resolve things by following the directions here: https://linuxpip.org/install-openssl-linux/

I suspect this is not an ideal solution, but it got things working for me. Posting here in case anyone else gets similar errors.
 

jomebrew

Forum Moderator
Grandmaster Brewer
Joined
Nov 6, 2010
Messages
1,057
Reaction score
2
That should be a good work around. 

I usually create a new symbolic link for older libs to the new lib after upgrading linux and breaking applications.

 

robfar

Apprentice
Joined
Jun 20, 2014
Messages
6
Reaction score
0
I've been using BeerSmith 3 in Ubuntu 22.04.1 for a long time, but recent upgrade to 22.04.4 broke BeerSmith good.  I don't even get an error message, it just spins the ball for a few seconds and quits.  Does this on two computers.
 

robfar

Apprentice
Joined
Jun 20, 2014
Messages
6
Reaction score
0
Installed Linux mint cinnamon on my old laptop and BeerSmith runs fine on it. Mint is based on ubuntu and there is an update coming in a few weeks, so I'll hold off proclaiming success.  I'll mess around with mint and if all goes well I'll say goodbye to ubuntu.  Any OS that won't run Beersmith is trash!
 

robfar

Apprentice
Joined
Jun 20, 2014
Messages
6
Reaction score
0
Linux Mint Cinnamon 21 LTS does not work with BS3.  All BS3 does when clicked on is spin a ball for a second and not open.  This is the same behavior in Ubuntu 22.04.04 LTS.

There should not be a version of Beersmith 3 for 22.04 LTS cause it won't work with the Ubuntu you can download now.

I hope Brad can fix this.
 

geigercounter120

New Brewer
Joined
Feb 22, 2017
Messages
2
Reaction score
0
I'm running Pop! OS (basically Ubuntu) v.22.04 and was having the same issue with BS3 clicking the icon, I had the 'I'm thinking about it' mouse pointer, then *nothing*.

Trying to open BS3 in the terminal, I got:

"beersmith3: error while loading shared libraries: libssl.so.1.1: cannot open shared object file: No such file or directory"

so following some guidance i found here (https://stackoverflow.com/questions/72133316/ubuntu-22-04-libssl-so-1-1-cannot-open-shared-object-file-no-such-file-or-di), I DLed the file "libssl1.1_1.1.1f-1ubuntu2.16_amd64.deb" from here: http://nz2.archive.ubuntu.com/ubuntu/pool/main/o/openssl/?C=M;O=D

and installed it.

Now BS3 opens fine for me

HTH
 

sgreene

Apprentice
Joined
Nov 11, 2017
Messages
10
Reaction score
0
libssl.so.1 and libcrypto.so.1 are both now obsoleted in Ubuntu 22.04 and Mint 21. Brad should think about building snap (or flatpack) versions. It would definitely lessen the ongoing support requirements as Linux updates its libraries.
 
Top