• Welcome to the new forum! We upgraded our forum software with a host of new boards, capabilities and features. It is also more secure.
    Jump in and join the conversation! You can learn more about the upgrade and new features here.

BS3.1 keeps telling me Another copy running

Ron

Apprentice
Joined
Oct 19, 2011
Messages
9
Reaction score
0
I deleted BS3.1 and then  reloaded it and it still says  "another copy running" I hit Run anyways and then tells me program not working. I am running win 7 have had this program for years never bee a problem till i went to BS3. Any suggestions?
 

enkamania

Master Brewer
Joined
Feb 7, 2011
Messages
54
Reaction score
0
I've found by closing all the modules with the red x and then close stops this.
 

jomebrew

Forum Moderator
Grandmaster Brewer
Joined
Nov 6, 2010
Messages
1,063
Reaction score
10
Did the document directory change? On one of the updates tp BS3, it changed my data directory from where it had always been (in mydocuments).  I started having this issue.

The issue is a .lck file it is in the data directory is not being deleted when BS3 closes. For some reason, windows or antivirus is keeping it locked. BS3 uses this file to determine if it is already running.  You can delete this lock file to get rid of the issue. it is in the data directory.

 

Ron

Apprentice
Joined
Oct 19, 2011
Messages
9
Reaction score
0
I deleted .lck and beersmith still tells me "another copy running"  I then deleted and restarted and still the same. I then deleted bs3 entirely and  downloaded it again, deleted .lck, same thing no luck.
 

jomebrew

Forum Moderator
Grandmaster Brewer
Joined
Nov 6, 2010
Messages
1,063
Reaction score
10
Are you running on Windows? Check this path for a lck file
C:\Users\YOURACCOUNTNAME\AppData\Roaming\BeerSmith3
 

Ron

Apprentice
Joined
Oct 19, 2011
Messages
9
Reaction score
0
deleted the .lck file  "in use"  from documents. Still says other copy running, I hit open beersmith anyways..BS3 stopped working. I am running win7.  I have deleted bersmith3, found .lck file deleted it,  reloaded B3. Still no luck. Sorry but i have tried everything.  It is allowed in my antivirus. I am willig to purchase it again if I know it would work.
 
Top