• Welcome to the new forum! We upgraded our forum software with a host of new boards, capabilities and features. It is also more secure.
    Jump in and join the conversation! You can learn more about the upgrade and new features here.

Ingredient not displayed in recipe View?

S

Sea

Not too computer savy here, but mine had a glitch and was restarted in Safe Mode, and now the ingredients pane is blank for all my recipes in the recipe view windows. All other info I entered is there, and if I highlight a recipe under the My Recipes list, it will display the ingredients in the bottom half of the screen.

What should I do?
 

BeerSmith

Staff member
Administrator
Grandmaster Brewer
Joined
Apr 5, 2003
Messages
5,888
Reaction score
67
Location
Virginia
Hi,
  Delete the "newopts14.opts" file from your BeerSmith directory - it is likely corrupt.  If you download the latest BeerSmith version from the download page it should keep this from happening again.

Cheers,
Brad
 
S

Sea

Thanks Brad,

I deleted the file, and updated, but still no Ingredients in thr pane. Any ideas?
 

BeerSmith

Staff member
Administrator
Grandmaster Brewer
Joined
Apr 5, 2003
Messages
5,888
Reaction score
67
Location
Virginia
Hi,
  Usually that fixes things.  I would next recommend making a complete copy of your C:\Program Files\BeerSmith directory, then delete it and reinstall.  Once you have reinstalled and it is working again, you can import the recipes and other date (Import and Merge on the File menu) to retreive your data.

Cheers,
Brad
 
H

hennigan

I recently encountered the same problem. Computer had a fatal error when I was away from it. When I restarted it everything looked ok until I opened BeerSmith and the ingredients pane was blank. I am running the latest version on VISTA. I tried to reinstall a couple times and somehow all the sample recipes I imported and 2 ones I created are always there even though I am doing an uninstall and deleting any beersmith files I can find. Apparently I am not deleting a file somewhere that I suspect may be the source of the corruption. Can you tell me how to proceed?
-Pete
 

BeerSmith

Staff member
Administrator
Grandmaster Brewer
Joined
Apr 5, 2003
Messages
5,888
Reaction score
67
Location
Virginia
Hi,
  Usually removing the "newopts14.opts" file works, but in extreme cases you may need to make a full backup, delete the entire BeerSmith directory (usually its "C:\Program Files\BeerSmith") and then reinstall and import your recipes back from your backup copy.

  if you get a chance, email the "newopts14.opts" file from your backup to me so I can look at it.

Cheers,
Brad
 
S

Sea

I am still having this same problem (been busy), and I too am running Vista. I tried copying and re-installing, but also get the program with all my recipes and the same malfunction. I removed all remnants of beersmith from my computer, but cannot get it to work.
 

BeerSmith

Staff member
Administrator
Grandmaster Brewer
Joined
Apr 5, 2003
Messages
5,888
Reaction score
67
Location
Virginia
Hi,
  Please check your shortcut to BeerSmith (right click on the shortcut and select properties).  In most cases the situation you describe (all your data stays when you remove everything) comes from having two copies of BeerSmith installed.  In some cases this is an issue when running an administrator account and non administrator account.

  Also - make sure the login you are using has write permission to the BeerSmith directory and its subdirectories.  This can be an issue if you installed BeerSmith as an administrator and run as a non-admin.

Cheers,
Brad
 
S

Sea

We only have an owner account on our computer, and I can't see any indication that 2 copies are installed.

How do I check for write permision in the directories?

Thanks, Seaira.
 

BeerSmith

Staff member
Administrator
Grandmaster Brewer
Joined
Apr 5, 2003
Messages
5,888
Reaction score
67
Location
Virginia
Hi,
  Check the properties of the C:\Program Files\BeerSmith directory and its subdirectories (templates especially).  Right click on the folder and click on "properties".  It should show if a directory is read-only.  For more detail you can look at the "Security" tab for the folder.

Cheers,
Brad
 
S

Sea

Thanks for the reply.

I tried to change from read only, and the computer does it, but still no dice. Then when I click on properties again, it displays read only still checked! I even tried restarting.

Any more ideas?
 

BeerSmith

Staff member
Administrator
Grandmaster Brewer
Joined
Apr 5, 2003
Messages
5,888
Reaction score
67
Location
Virginia
Hi,
  You may need to be an administrator to change the permissions on the folder.  Try logging in as an admin and giving the non-admin user permission to the files/directory.

Brad
 
S

Sea

Allright Brad, here's a new one for ya:

After trying all of your suggestions and effing around with everything I could imagine, I got Beersmith completely off my computer. I had burned a complete copy of the file to CD a while back when this all started, and I also just saved a copy to my external drive. So the new install went as desired, but when I tried to import and merge, it didn't go so well. Here's the thing: When I import the Recipe file, I get only one of my old recipes. It's not the first, or last one I entered, but somewhere in the middle!?!

Any ideas on how to get the rest of my recipes back?
 
S

schneemann

I have also had this problem and have been unable to resolve it using any advice in this thread.

Windows Vista SP1
Beersmith 1.4
Build 037
I am an administrator on this machine.

In June, I got the dreaded BSOD and immediately upon restart, I opened BeerSmith and noticed the ingredients pane is blank when in recipe view.

I came here and saw this thread and at the time there wasn't much advice at the time. 

I attempted to uninstall BeerSmith and all remnants of it from the computer.  I shut the computer down after uninstall then restarted and reinstalled. Same issue remained. 

The odd thing is that my recipes were repopulated after the reinstall.

A few weeks later, I came back to this thread and saw some guidance had been offered.

I've looked for a 'newopts14.opts' file on my computer and it doesn't exist at all.

I've ensured that there are no shadow copies.

I've uninstalled and reinstalled.

Your assistance would be very much appreciated.


 

BeerSmith

Staff member
Administrator
Grandmaster Brewer
Joined
Apr 5, 2003
Messages
5,888
Reaction score
67
Location
Virginia
Hi,
  Its a longshot, but I have been beta testing this patch to address some problems found by others.  You are welcome to give it a try.

    Here's the patch link: http://beersmith.com/beersmith_patch.zip

  The patch contains only the executable, so you will need to manually drop this into your BeerSmith directory.

  I am a bit concerned also that you mention your recipes getting repopulated after the reinstall.  This should not happen at all since you just deleted them when you removed the BeerSmith directory.  You might want to check the shortcut you are using (right click on properties) to see from what location you are running BeerSmith.  The default location is "C:\Program Files\BeerSmith".  Several people have had more than one copy running which creates many problems.

Cheers,
Brad
 
S

schneemann

OK, I've gotten this sorted now.

Previous to this, when I reinstalled BeerSmith, it never walked me through any of that setup stuff.  This, despite the fact that I uninstalled if from the control panel, removed the folder from "C:\Program Files\BeerSmith" and even edited my registry to remove all mentions of BeerSmith.  Additionally I ran Vista's disk cleanup everytime I uninstalled and reinstalled.

I went through this routine 4 times. Each time the problem remained.

Then I ran an advanced search in Vista on the string 'beersmith'.

What I found was a directory within "C:\Users\username\AppData\Local\VirtualStore" which had backups of all of the contents of "C:\Program Files\BeerSmith"

To be extra anal, I deleted every single reference to BeerSmith that my advanced search found (which included my recipes which I backed up elsewhere. (Though I'm 99% sure all I needed to eliminate was the content of the VirtualStore

I removed this, turned the computer off all the way, re-downloaded BeerSmith and reinstalled it.  Everything looks OK so far.

 
S

schneemann

Just another update, this is definitely resolved.  I used BeerSmith for about an hour last night and have been using it during this morning's brew session without any problems.  I've been adding, editing, deleting, and moving recipes around and have started, closed and opened BeerSmith several times and everything is working great.
 

BeerSmith

Staff member
Administrator
Grandmaster Brewer
Joined
Apr 5, 2003
Messages
5,888
Reaction score
67
Location
Virginia
Yes,
  I just found out about the virtual store under Vista which is apparently the reason many people have this problem and it does not go away.

  This should work:
  - Close BeerSmith (you don't want it running here)
  - Go to C:\Program Files\BeerSmith  (under Vista) using file explorer
  - Click on the "Compatability Files" icon on the explorer toolbar in Vista
  - Now delete the "newopts14.opts" file
  - Open up BeerSmith

Thanks very much for finding this!!  Apparently under Vista the files get stored to this compatibility directory if you don't have direct permission to the Program Files directory.

Brad
 

BrewWhat

Brewer
Joined
Sep 20, 2008
Messages
30
Reaction score
0
Location
Rural Middle Tennessee
A lot of times when you delete a program they leave Registry entries on your computer. To get a full removal delete your program using the add / remove programs in the control panel and then use a registry cleaner (such as CCleaner) to remove left overs from your removal.
 
Top