• Welcome to the new forum! We upgraded our forum software with a host of new boards, capabilities and features. It is also more secure.
    Jump in and join the conversation! You can learn more about the upgrade and new features here.

BeerSmith 2 Linux Open Beta

BeerSmith

Staff member
Administrator
Grandmaster Brewer
Joined
Apr 5, 2003
Messages
6,209
Reaction score
125
Location
Virginia
All,
  I just posted the first "open beta" of BeerSmith 2 for Linux.  The initial build is a 32-bit
Debian package targeted towards the popular Ubuntu build (Intel platforms). 

  Update 27 Jan - The 64 bit Ubuntu/Debian build is also now on the main download page.

  The download is on our main download page:
    http://www.beersmith.com/download-beersmith/

  It has all of the functionality of the PC and Mac BeerSmith 2 programs.  It does, however
store the data under ~/.beersmith2 instead of the Documents/BeerSmith2 directory
used for other platforms.

  I'm planning to submit it to the Ubuntu store in the near future.

  Please post major Linux bugs with the beta to this thread which I will be monitoring.

Cheers,
Brad
 
Awesome timing.

Just bought a small netbook that I've installed Linux Mint on, can't wait to give this a shot.

Cheers.
 
http://i42.tinypic.com/o69z4h.jpg

Having trouble on Ubuntu 11.10

Thanks for the Linux release though! Very excited to put this on my desktop and my netbook
 
All
  Had a small bug in the download script which someone found a few minutes ago - I've corrected it and the package should download and install now if you have the Debian package manager on your system.

Brad
 
Will there be a 64 bit .deb available?  Error: Wrong architecture 'i386' is the message i get when I try to install this on my 64 bit system.

Thanks
 
Hi,
  I don't have a 64 bit build yet but I believe one of the beta testers said if you force it to install on your 64 bit system it will work OK at least under Ubuntu 64 bit.

  dpkg --force-architecture -i BeerSmith-2.0.60.deb

Brad
 
BeerSmith said:
Hi,
  I don't have a 64 bit build yet but I believe one of the beta testers said if you force it to install on your 64 bit system it will work OK at least under Ubuntu 64 bit.

  dpkg --force-architecture -i BeerSmith-2.0.60.deb

Brad

I tried this.  It will install and take activation key, but fails with multiple errors before fully loading.  I will wait for the 64 bit if one is planned.

Thanks
 
Strange,
  I created a Virtual Machine today and loaded the latest release version of Ubuntu 64 bit.  Then I installed the DEB package with the command here:
    sudo dpkg --force-architecture -i BeerSmith-2.0.60.deb

  The program seems to run fine under this version (64 but Ubuntu 11.10) if you do a force install.

  Are you running a different version of Ubuntu or Linux?

Brad
 
I had the same issues and it turned out to have to do with not having i386 versions of my GTK theme installed. In my case, installing the package gtk2-engines-xfce:i386 fixed the issue described. Ultimately, problems like this will probably pop up a lot depending on user configuration, so a 64-bit version will be important.

I found some info that may be helpful to people here: http://maketecheasier.com/run-32-bit-apps-in-64-bit-linux/2009/08/10
 
First, thanks for finally supporting Linux.  I'm happy to rid of WINE from my system.

I have created a spec file that converts the .deb into an RPM and requires all of the right dependencies on F16.

Do you have plans to support a proper RPM for Fedora in the future?  There were only two bugs I came across when packaging it:
1. there is a static rpath in the 'beersmith2' binary.  I had to disable rpath checks in the spec file to avoid an error.
2. you link against a newer version of wxWidgets compared to what ships in F16, so we still need to ship your local copies.  Is this a hard dependency or if you recompiled on F16 would things be fine?  It would be nice to not redistribute libraries that are already in the distro.

spec: http://aronparsons.s3.amazonaws.com/beersmith.spec
RPM: http://aronparsons.s3.amazonaws.com/beersmith-2.0.60-1.fc16.x86_64.rpm
 
Hi,
  The 64 bit Ubuntu/Debian package is now online at the main download page.

  I'll be looking at other builds shortly (Fedora, Slackware).

Brad
 
Running Ubuntu 11.10 x86 on a netbook. I have BeerSmith docked in my Unity bar when I click it to run it starts up fine but it seems that the desktop does not know it is running. While BeerSmith is running the Unity bar BeerSmith icon does not have the mark that it is running. If I hit alt+tab it does not show up as an option to switch to. If I minimize the BeerSmith window it is completely lost and can not be brought back up. Initially the file bar at the top is not the BeerSmith one, it maintains the previous program that had focus last. However, when I maximize BeerSmith it does show the file menu bar. One thing to note is that it does show up in the processes list so I can kill it if the window gets lost.  If I try to click the unity icon again I get a msg saying only 1 version of BeerSmith can run at a time. Being a netbook, and having small screen real estate, I run most applications at full screen and switch to each app using the unity bar or alt+tab. To use BeerSmith after switching focus to another app I have to minimize that app to get control of the BeerSmith window again. Not sure if anyone else running a similar setup is seeing this or if I am alone with this issue. Everything else that I have used it for seems to be fine.
 
Thanks,
  I have the stock 11.10 32 bit Ubuntu running here on a full size machine and when I start BeerSmith it does show the indicators for a running program (little triangles on the bar).  Also minimizing does work (it goes to one triangle, but clicking on the icon brings the whole program back).  Finally I'm not seeing the menu issue either.  I tried maximizing the program and alt-tabbing between it and a maximized firefox web browser and it works OK (with menus).

  I'm wondering if it might be an issue with the smaller screen format and compact unity bar on the notebook?

Brad
 
Thanks for looking at this. I just re-booted, which I did before to see if it would fix my issue and it seems to work now  :eek:. Only thing is when BeerSmith started up it mentioned something about deleting a stale lock file.
 
Hi! I just installed BS2 in 64 bit kubuntu 11.10 and 32bit debian wheezy. They both run fine.
The only thing I found so far is that "tab" change only on the menu bar, not the rest of the windows.
i.e: When I modify a mash profile I had to click with the mouse on every button to change amounts, etc. Same with calculation tools, etc
Thanks in advance
Martin
 
Thanks
  I was not aware of the tab issue - I'll take a look at it.

Brad
 
thanks so much for the native linux version!
I have it installed on my (debian-based) netbook and it's working quite well.

one issue that I noticed:

- changing the units to metric in the options causes all the default field values on that form to be 'doubled' like: ".2500.2500" or "$$" for the currency sign. These values will then be used like that when making a recipe, etc. Changing unit sets again (to US, say) will do it again, so you can end up with very long nonsense ".2500.2500.2500" values in there. this then has some funny effects in the various recipe calculations. Manually editing those values back to something normal works fine though - it's just that 'switch all values to metric/US' button that does it.


Also, a package for Fedora (or a generic release) would be amazing! (that's my main desktop)
Would love to stop mucking about with wine (even though it works surprisingly well)

thanks
 
running this on Linux Mint. working GREAT! I did notice that if I pin the app to the panel and then minimize the only way get back to the app is to alt-tab. clicking on the icon again in the panel gives an error that the app is already running. It's like the app disappears when minimized. Also being able to export recipes in XML would be awesome.

Thanks for making a native Linux version, it makes life MUCH easier since I now use Linux as my main OS. It also helped convince a friend to buy Beersmith
 
Just installed and tested out the 64-bit version on Ubuntu 11.10. Works great so far! Thanks for a Linux client!!
 
I am running LinuxMint 12, 32 bit.

When trying to export a recipe in any of the 3 formats I get a dialog box stating "Writing files of this type not yet completed" I have reinstalled BeerSmith2 and the dialog persists.

Thanks,
Mike
 
Back
Top