• Welcome to the new forum! We upgraded our forum software with a host of new boards, capabilities and features. It is also more secure.
    Jump in and join the conversation! You can learn more about the upgrade and new features here.

BeerSmith 3.1 Open Beta Download Available

Brew Bama

Master Brewer
Joined
Apr 29, 2014
Messages
69
Reaction score
5
Location
Huntsville AL
Thanks for adding Tilt to the build!

Any thought to using ?grams? for dry yeast instead of ?package??  It might not be common across the hobby but I use Lallemand?s pitch rate calculator which rarely recommends the weight of one package.

Again, thx for the great product!
 

bbbullock

Apprentice
Joined
Dec 26, 2018
Messages
8
Reaction score
0
Still not able to print in 3.1.07 on Mac running MacOS 10.15.6.  See attached error message from browser (Safari).  What might I be doing wrong?
 

Attachments

  • Screen Shot 2020-08-08 at 4.01.40 PM.png
    Screen Shot 2020-08-08 at 4.01.40 PM.png
    80.6 KB · Views: 454

beerprof

Brewer
Joined
Sep 9, 2014
Messages
38
Reaction score
0
Location
Oswego, NY
First, are you sure you're using 3.1.07? I only ask because I'm running 3.1.07 on OSX 10.15.6, same as you and don't have a problem. I thought the "localhost" issue was resolved with this update as indicated by the fact that if I send output to the default browser, it says file:// not localhost. Granted my default browser is Firefox and not Safari, but I don't think that's a problem.

edit: just tried sending to Safari and it worked just fine.
 

bbbullock

Apprentice
Joined
Dec 26, 2018
Messages
8
Reaction score
0
beerprof said:
First, are you sure you're using 3.1.07? I only ask because I'm running 3.1.07 on OSX 10.15.6, same as you and don't have a problem. I thought the "localhost" issue was resolved with this update as indicated by the fact that if I send output to the default browser, it says file:// not localhost. Granted my default browser is Firefox and not Safari, but I don't think that's a problem.

edit: just tried sending to Safari and it worked just fine.

Yes, confident.


 

Attachments

  • Screen Shot 2020-08-09 at 10.54.09 AM.png
    Screen Shot 2020-08-09 at 10.54.09 AM.png
    431.3 KB · Views: 461

BeerSmith

Staff member
Administrator
Grandmaster Brewer
Joined
Apr 5, 2003
Messages
5,714
Reaction score
12
Location
Virginia
For printing, some print drivers have issues.  Try going to Options->Reports and check the Print to Browser box which will send printouts to the browser where you have more control over scaling, margins and printing.

Brad
 

bbbullock

Apprentice
Joined
Dec 26, 2018
Messages
8
Reaction score
0
BeerSmith said:
For printing, some print drivers have issues.  Try going to Options->Reports and check the Print to Browser box which will send printouts to the browser where you have more control over scaling, margins and printing.

Brad

The Print to Browser option is checked and results in the error.








 

bbbullock

Apprentice
Joined
Dec 26, 2018
Messages
8
Reaction score
0
Just discovered that the "Brew Steps" will print to the browser ok.  The "Shopping List" produces the error as reported in Safari below.



bbbullock said:
BeerSmith said:
For printing, some print drivers have issues.  Try going to Options->Reports and check the Print to Browser box which will send printouts to the browser where you have more control over scaling, margins and printing.

Brad

The Print to Browser option is checked and results in the error.







 

BeerSmith

Staff member
Administrator
Grandmaster Brewer
Joined
Apr 5, 2003
Messages
5,714
Reaction score
12
Location
Virginia
Thanks - I will take a close look at the shopping list code as it has a different path.  I'm finishing up a minor update in the next few days and hopefully I can find root cause.

Brad
 

BeerSmith

Staff member
Administrator
Grandmaster Brewer
Joined
Apr 5, 2003
Messages
5,714
Reaction score
12
Location
Virginia
I put together a 3.1.8 fix for the print to browser shopping list issue.  Its in this version which is in beta but will likely be released soon:
  https://beersmith3-1.s3.amazonaws.com/BeerSmith3_1_8.exe  -- Windows
  https://beersmith3-1.s3.amazonaws.com/BeerSmith3_1_8.dmg  -- Mac

Brad
 

bbbullock

Apprentice
Joined
Dec 26, 2018
Messages
8
Reaction score
0
Thanks!  I downloaded/installed the 3.1.08 beta and the shopping list print now works.
 

brewfun

Grandmaster Brewer
Joined
Sep 6, 2011
Messages
2,305
Reaction score
0
Location
Ventura, CA
Bug report:
When using the substitute button for misc items in the design tab, the fermentables list opens instead of the misc list. Water, fermentables and hops all seem to open the correct lists.
 

Oginme

Grandmaster Brewer
Joined
Mar 16, 2013
Messages
3,156
Reaction score
1
Location
New Hampshire, US
brewfun said:
Bug report:
When using the substitute button for misc items in the design tab, the fermentables list opens instead of the misc list. Water, fermentables and hops all seem to open the correct lists.

Interesting.  When I just tried it, the pop-up box for selection was labeled "add fermentables", but the ingredients listed were all from the "Misc" listing.
 

BeerSmith

Staff member
Administrator
Grandmaster Brewer
Joined
Apr 5, 2003
Messages
5,714
Reaction score
12
Location
Virginia
Thanks,
  I tried it here but for me the Misc box showed up.  Are you sure you only have one item (not multiple) selected when doing the substitute?

Brad
 

bougie1st

Master Brewer
Joined
May 21, 2016
Messages
76
Reaction score
0
I saw the same as Oginme - single item selected. Lists misc items, but the heading says 'add fermentables'
 

BeerSmith

Staff member
Administrator
Grandmaster Brewer
Joined
Apr 5, 2003
Messages
5,714
Reaction score
12
Location
Virginia
Got it- I thought it was the listing that was wrong but it looks like just the title is wrong.

Brad
 

TestTickle

Apprentice
Joined
May 1, 2018
Messages
11
Reaction score
0
I posted this on another thread but haven't heard anyone having the issue. After upgrading to 3.1 on Windows 10, when I copy a recipe to the cloud, I am seeing a duplicate. The first time it happened, I thought it was an accident on my part, so I deleted one copy. When I went back, the recipe (along with the duplicate) were both gone. It was then that I realized that it was not actually a duplicate, it was just SHOWING a duplicate. Refreshing didn't fix it. When I close and re-open the program completely, the duplicate disappears leaving only one the one copy. I am now running 3.1.08 and the problem still exists, and it happens every time I copy a recipe to the cloud.

Anyone else experience this behavior?
 

BeerSmith

Staff member
Administrator
Grandmaster Brewer
Joined
Apr 5, 2003
Messages
5,714
Reaction score
12
Location
Virginia
I tried a few tests here but I'm not seeing that happen.  How are you copying to the cloud?  Is it using the Copy to Folder button or using a copy/paste operation?

Brad
 
Top